Get and install LibreOffice

LibreOffice is available to download and install in various versions depending on

  • The platform (Linux, Windows, Mac)
  • The interface language and tools
  • The software version (5.1, 5.2, 5.4 etc)

Language support

Every LibreOffice installation file includes support for a specific language. Language support includes the application user interface language (menus, toolbars, help) and language tools (spelling, dictionaries, hyphenation, synonyms).

Therefore when you download LibreOffice for installation, you need to be careful when choosing the language. Of course, you can install additional languages ​​later in LibreOffice but it will save you a lot of trouble installing the version with your primary language.

Note that the keyboard input language depends on your system settings and not on LibreOffice. For example, if you want to type with Greek characters, there must be installed in your Operating System the Greek input method.

Installing on Linux

If you are using a major Linux distribution such as Ubuntu, Mint or Mate then LibreOffice is already installed by default with your Linux operating system.

You may only need to add support for another language. The easiest way to do this is to add that language to the Operating System interface languages. After you do this you can easily change the LibreOffice interface language and tools.

Manually install on all platforms

Before installing, you must download the correct installation file according to the platform and language.

  1. Go to the LibreOffice downloads page,
  2. The page automatically detects your operating system and language
  3. If you want to download for another Operating System, use the drop-down menu on the right.
  4. If you need LibreOffice in another language click on the need another language link and choose your language.
  5. Click the Download button, optionally, download the offline help
  6. Run the installer and follow the instructions for Windows and Mac.

LibreOffice language and version for this course

To follow this course you will need to install the English version of LibreOffice. Also note that the course material was made with version 5.1, therefore you may see some differences in the user interface with regard to your own version. However we believe that these small changes will not make it difficult for you to understand the lessons.

Last modified: Saturday, 17 February 2018, 1:39 PM