For this course, you need...

What do you need to participate in this course?

It is necessary that the browser you are using to be updated to its latest version. The course can be viewed with all the modern browsers, for example, Firefox, Opera, Internet Explorer, Chrome, Safari.

  • To write code (modules1-10) we recommend using the code editor Visual studio editor, but you can use whichever suits you better.
  • To build scalable network applications you need the Node.js. Installing this you have also downloaded in your computer the NPM  a large ecosystem of open source libraries. See here to install node.js on Linux.
  • To track changes in computer files you need the Git the version control system. 
  • To share your projects to Github you have to create an account.
  • To upload your projects onto our WEB server you need the Filezilla, an SFTP program.

All the programs used in this course are free and open source.

Last modified: Monday, 7 May 2018, 6:04 PM